Hyundai Venue Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi, first of all I wanted to mention I've been lurking this forum for awhile and it's wonderful to see there's a place to see how other's have been mod'ing their Venues!

Issue: Bought my car very recently. The headlight "OFF" mode does not actually turn off (disable) any lights. It appears to be essentially stuck in "AUTO" mode. In "OFF" mode, when I drive through a dark tunnel, my headlight would turn on (along with the 2 green light indicators on dash). This should only happen in "AUTO" mode. Is this a defect or some setting I can toggle in the sw?
 

·
Registered
2021 Hyundai Venue Preferred
Joined
·
456 Posts
I just checked my 2021 Canadian Preferred model headlight switch. OFF is OFF. When sitting in the dark, engine running, in AUTO my headlights come on. When set to OFF the headlights go OFF, DRL are on until I set the parking brake. Seems you're headlight switch is stuck in AUTO for some reason. Best to get the dealer to take a look.
 

·
Registered
Joined
·
482 Posts
I agree. On my 2020 SE, OFF means OFF and ON means ON. It doesn't sound like it's a very serious problem, but it does sound like it is a malfunction worth getting checked out.

On a side note, I think the AUTO feature is kind of cool, but I refuse to use it. I have trained myself over the years to always turn my headlights off, even if they weren't on, as I turn the ignition key to OFF. I'd hate to ruin all those years of conditioning when I might need it again some day with a different car.
 

·
Registered
Joined
·
1 Posts
Hi @pistachio, have you sorted this out?

I got my brand new 2022 Venue Preferred a few days ago, and I'm experiencing the same thing: "off" setting behaves exactly as "auto". Actually, I've noticed one minor difference: when I shift to P (or pull up the hand brake when not moving while still on D), the "off" setting behaves as expected and the lights turn off.

I feel like this could be a security feature to prevent people from driving around at night with the lights off, but I'm still a bit concerned it could be a firmware bug. I can't find anything about it in the owner's manual. I'd be curious to know if you found out what is causing this.
 
1 - 5 of 5 Posts
Top