Hyundai Venue Forum banner
1 - 6 of 6 Posts

Registered
Joined
2 Posts
Discussion Starter · #1 ·
My wife is experiencing info screen problems. Rear camera not stopping, when driving forward, screen going blank and coming back on.
It has happened about 4 or 5 times since our 12 month service in Dec 2021 when I assume a software or maps update was done.
It ceases when car is turned off and back on again!
I know others in the US/CANADA have experienced this as well and I'd appreciate if you could share the resolution to the issue?
Thanks
Peter
 

Registered
2021 Hyundai Venue Preferred
Joined
324 Posts
I can only speak to Canada and my dealer. On my 1 year service an infotainment update was available and they didn't offer to install it. Hyundai Canada sent me an email informing of the availability of the update and installation instructions. I suppose I could have paid them to install it but I did it myself. Under the Canadian warranty the infotainment system is warranty covered for 36 months/60,000km.
Your system may be covered by your warranty. I wouldn't mess with it and would get the dealer to repair it under warranty.
However, if you want to try something easy, disconnect the battery negative cable for a few minutes to drain all power from the electronics. If the power reset doesn't fix it. You could try a more risky procedure, re-flash the latest firmware for your country/model to refresh the software. The problem with that, given your issues, if the system kicks out in the middle of the flash, you could be left with a brick.
You most likely have a hardware problem in the unit. Best bet is to try and get dealer to fix it under warranty. More than likely the entire head unit will be replaced and your old one will be sent to a repair center to be refurbished and put back in stock.
 
  • Like
Reactions: venue1947

Registered
Joined
9 Posts
I have the same intermittent issue on my 2020 Venue in Australia. Happens about once a week. It started (I think) after updating the firmware in May 2021. Usually happens if I'm dropping someone off and waiting for them in the car without me getting out and when they return, I need to reverse for a short distance to get out on the road. If I just open the door with the ignition off, while waiting for them, it usually doesn't happen. Weird. I just use Google maps and ignore it. Next time I turn off and back on the problem has gone. But if you find a resolution I would be interested. Before last years update I didn't have a problem.
 

Registered
Joined
42 Posts
Twice now my display has gone nuts... jittering, switching between screens rapidly and just generally acting as if it's possessed. Next time it happens I'll take video so I can show the guys at the dealership that this is a real thing.
 
1 - 6 of 6 Posts
Top