Hyundai Venue Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
184 Posts
Discussion Starter · #1 ·
My Venue turned a year old last month. Some of youse guys may be in a similar situation. How has the year gone (for your VENUE, I mean! Not in general!!)

I haven't had any mechanical issues. No defects in materials or workmanship. A few months ago my TPMS told me all my tires were low on air, but that's the worst thing that happened. Of course, I only drove about 2500 miles in all that time, so I didn't exactly beat it into the ground. Looking back, I'm still very satisfied with my purchase.

Anyone else pass their one year Venueversary yet? What do you think?
 

·
Registered
2021 Galactic Gray SLE
Joined
·
1 Posts
My Venue turned a year old last month. Some of youse guys may be in a similar situation. How has the year gone (for your VENUE, I mean! Not in general!!)

I haven't had any mechanical issues. No defects in materials or workmanship. A few months ago my TPMS told me all my tires were low on air, but that's the worst thing that happened. Of course, I only drove about 2500 miles in all that time, so I didn't exactly beat it into the ground. Looking back, I'm still very satisfied with my purchase.

Anyone else pass their one year Venueversary yet? What do you think?
I’m a month into ownership and I’m really enjoying the car. However...I will be returning to my dealership in order to check out an ongoing issue concerning a popping noise emmiting from my front wheels when turning while backing up. Only occurs when backing out my driveway after sitting overnight.
Streering linkage, tie rods, wheel bearings, motor mounts....who knows? Just hoping it can be resolved quickly.On another occassion my infotainment screen stayed blank after staring the car, came back on after re-starting and has been ok since. One week and counting..
 

·
Registered
Joined
·
12 Posts
My Venue turned a year old last month. Some of youse guys may be in a similar situation. How has the year gone (for your VENUE, I mean! Not in general!!)

I haven't had any mechanical issues. No defects in materials or workmanship. A few months ago my TPMS told me all my tires were low on air, but that's the worst thing that happened. Of course, I only drove about 2500 miles in all that time, so I didn't exactly beat it into the ground. Looking back, I'm still very satisfied with my purchase.

Anyone else pass their one year Venueversary yet? What do you think?
March 1st will be a year since I bought my Venue. I must say the car has exceeded expectations. I needed a city run-about that could squeeze into my tiny parking space. I got that and more. The fit and finish was perfect, with nice even panel gaps and no rattles, squeaks or leaks, something I could not say about my previous Honda. The car has had no trips to the dealer (knock wood) and has been rock solid mechanically. The easy, intuitive tech, the up to date safety suite, the IIHS Top Safety Pick Rating and the long warranty were the major selling points. On a recent trip to BestBuy, we were able to slide a 55 inch TV, flat onto the load bed and up against back of the front seats. Easy-peasy, love a hatchback! I've added tint,Tuxmat snow mats, wheel locks and am considering upgrading the sound system. Look, the car could use a bit more power, height adjustable seat belts and adaptive cruise control, etc. but really, it's loaded for an entry level vehicle. The Venue is not for everyone but for us it has been fun, safe, reliable and easy to park. No buyers remorse, here.
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #4 ·
.....I needed a city run-about that could squeeze into my tiny parking space. I got that and more.....
Me too. I rarely leave the city, and the Venue is great for zipping around the crowded streets, and parking anywhere you want. I still haven't used the cruise control and can't imagine I ever will. It would indeed be underpowered if I had the CVT, but with the manual transmission, it is as powerful as it ever needs to be!
 

·
Registered
Joined
·
1 Posts
Well it's not been an year for me. More like 6 months. I don't know whether I should be worried, but until a few weeks back the reading on the coolant temperature gauge used to hover around two bar Mark ( i.e. two bars from the cold end of the gauge). However off late I see that it almost rises to the halfway point( stopping one bar below it). I am from India and mostly use the car for city drive occassionally on the expressway. Does anyone have any views on whether this is ok ( the temperature gauge issue).
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #6 ·
Well it's not been an year for me. More like 6 months. I don't know whether I should be worried, but until a few weeks back the reading on the coolant temperature gauge used to hover around two bar Mark ( i.e. two bars from the cold end of the gauge). However off late I see that it almost rises to the halfway point( stopping one bar below it). I am from India and mostly use the car for city drive occassionally on the expressway. Does anyone have any views on whether this is ok ( the temperature gauge issue).
I just got back from an hour running errands (all city stop-and-go driving). I paid attention to the temperature gage. When I first start the car, it goes to the two-bar mark, but after a block or two of driving, it always went to almost the halfway mark. Sounds like yours is normal.
 
1 - 6 of 6 Posts
Top